OpenJDK Vulnerability Advisory: 2021/04/20

The following vulnerabilities in OpenJDK source code were fixed in this release. The affected versions are 16, 15.0.2, 13.0.6, 11.0.10, 8u282, 7u291, and earlier. Please note that defense-in-depth issues are not assigned CVEs. We recommend that you upgrade as soon as possible.

The current and previous advisories are available for reference.

OpenJDK Risk matrix

Affects ...
CVE ID Component CVSSv3.1 7 8 11 13 15 16
CVE-2021-2161 core-libs/
java.io
5.9
CVE-2021-2163 security-libs/
java.security
5.3

OpenJFX Risk matrix

Affects ...
CVE ID Component CVSSv3.1 7 8 11 13 15 16
None

Acknowledgements

We acknowledge the following party for their reports and contributions: Artem and Markus Loewe.

We also thank the Leads of the JDK 7 Updates, JDK 8 Updates, JDK 11 Updates, JDK 13 Updates, JDK 15 Updates, and OpenJFX Projects for providing the risk-matrix information for their releases.

How to report a vulnerability

Please see the reporting instructions for information about how to report a vulnerability.

Last update: 2021/04/23 18:10 UTC